Error while retrieving/submitting my filled DS160 application?

“An unexpected error has occurred while processing your previous request. The error has been reported to the site administrator; no further action is required. To retrieve your DS-160 application, please enter your Application ID.”

This is the error i got every time I click next page and i gotta retrieve application once again. Is this a matter of concern?

Even I am not able to upload the application saved(.dat file). same error. what to do? it usually happens in Saturdays?( Friday nights - US time). Quick answer would be helpful. i am worried

1 Like

Got into same issue. Filled DS160 half way on Friday night IST. Came to complete it on Sat morning IST and whole day getting message “The error has been reported to the site administrator; no further action is required.” upon clicking on “Save” or “Next” button within the form.

Unable to proceed at this point.

Seems like some new application issue that should get resolved in some time. Waiting and trying again every few hours !

so what should we do now? wait till monday or just go on with a new one? any suggestions

I got through this morning. Looks like the application glitch is now resolved.

yes great. going good now. thanks buddy. wishmegoodluck :smiley:

I am still facing the same problem…can u please let me know whether have u created a new application or gone through with the old application

I’m still getting “The error has been reported to the site administrator; no further action is required.” when trying to confirm my photo, which is saying has met the standards with a big green correct sign beside it, any help would be much appreciated

I’m getting the same error too. Trying to fill in the D160 before booking my interview for a C1/D visa. Application all filled out correctly but when I confirm my photo I get “The error has been reported to the site administrator; no further action is required.” Not quite sure how to proceed! I have 2 months to get this visa before I start a job as a performer on a cruise ship!

kcleworth, thats 100% identical to mine, i’ve tried using google chrome but same error, so browser issue can be ruled out, I’ve no idea where to go from here.

There was a problem of server error on saturday Indian time. It got sorted out On Monday and we could proceed smoothly.

Things look ok in India now

Yeah, I’ve tried 3 times now and on 3 different browsers. Kinda stressing me out because I just want to get my interview booked and everything confirmed! WCAMPION are you in the UK?

Still not working in the UK. Application error after photo section.

Im in Ireland, ahh the stress yes Im there as well, fingers crossed something happens soon

Absolute nightmare. I’m not flying till April but it’s still annoying me.

patience… patience… its not a browser issue… will be sorted in a night time. hope you all will get through

who’s night time wishmegoodluck, US or Europe

I m having exact same problem in asia. Will US government web maintenance solve the problem today? Anyone able to get application through?

It’s George Washington’s Birthday today… So the embassy is closed. Maybe that is causing an issue? :stuck_out_tongue:

the same in France…isn’t there a way to contact a personn responsible for it?

Websites are slightly different for Europe and india.
Though basic website remains,
For us it is-
For others, it is respective country.
Surely They are aware of problem and would be working on it